Labels

Senin, 27 Agustus 2012

QoS + Loadbalance+external Proxy

Langkah Pertama

  1. Rokok Wajib
  2. Obat nyamuk 
 Disini saya hanya mendocumentasikan apa yang sudah pernah saya buat pada router saya, sekiranya berguna juga untuk router anda silahkan di gunakan :D 






Setting Interface dan IP Address

 
 /interface ethernet
set 0 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=no disabled=no full-duplex=yes mac-address=\
    00:23:CD:B2:98:C6 mtu=1500 name=speedy-jalur-1 speed=100Mbps
set 1 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=no disabled=no full-duplex=yes mac-address=\
    74:EA:3A:85:8B:0C mtu=1500 name=proxy speed=1Gbps
set 2 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=no disabled=no full-duplex=yes mac-address=\
    00:C0:26:20:C5:88 mtu=1500 name=to_hotspot speed=100Mbps
set 3 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=no disabled=no full-duplex=yes mac-address=\
    00:20:ED:44:27:11 mtu=1500 name=Hotspot_Centralized speed=100Mbps
set 4 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=no disabled=no full-duplex=yes mac-address=\
    00:E0:4C:44:B6:92 mtu=1500 name=speedy-jalur-2 speed=100Mbps
set 5 arp=reply-only auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=no disabled=no full-duplex=yes mac-address=\
    00:23:CD:B2:8D:C9 mtu=1500 name=local speed=100Mbps



 
/ip address
add address=192.168.178.1/24 broadcast=192.168.178.255 comment="" disabled=no \
    interface=local network=192.168.178.0
add address=192.168.12.1/24 broadcast=192.168.12.255 comment="" disabled=no \
    interface=to_hotspot network=192.168.12.0
add address=192.168.7.1/24 broadcast=192.168.7.255 comment="" disabled=no \
    interface=local network=192.168.7.0
add address=192.168.90.1/24 broadcast=192.168.90.255 comment="" disabled=no \
    interface=local network=192.168.90.0
add address=192.168.32.1/28 broadcast=192.168.32.15 comment=\
    "IP class Lintang" disabled=no interface=local network=192.168.32.0
add address=192.168.121.2/24 broadcast=192.168.121.255 comment="" disabled=no \
    interface=speedy-jalur-1 network=192.168.121.0
add address=192.168.123.2/24 broadcast=192.168.123.255 comment="" disabled=no \
    interface=speedy-jalur-2 network=192.168.123.0
add address=192.168.45.1/24 broadcast=192.168.45.255 comment="" disabled=no \
    interface=proxy network=192.168.45.0
add address=192.168.55.1/24 broadcast=192.168.55.255 comment="" disabled=yes \
    interface=Hotspot_Centralized network=192.168.55.0

/ip firewall nat

 add action=masquerade chain=srcnat comment="" disabled=yes out-interface=\
    speedy-jalur-1
add action=masquerade chain=srcnat comment="" disabled=yes out-interface=\
    speedy-jalur-2
add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    pppoe-speedy1
add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    pppoe-speedy-2
add action=dst-nat chain=dstnat comment=DNS disabled=no dst-port=53 \
    in-interface=proxy protocol=udp to-ports=53
add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 \
    in-interface=proxy protocol=tcp to-ports=53
add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 \
    in-interface=local protocol=udp to-ports=53
add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 \
    in-interface=local protocol=tcp to-ports=53
add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 \
    in-interface=to_hotspot protocol=udp to-ports=53
add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 \
    in-interface=to_hotspot protocol=tcp to-ports=53
add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 \
    in-interface=Hotspot_Centralized protocol=udp to-ports=53
add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 \
    in-interface=Hotspot_Centralized protocol=tcp to-ports=53
add action=dst-nat chain=dstnat comment="NAT PROXY" disabled=no dst-port=\
    80,81,8080,3128 in-interface=local protocol=tcp to-addresses=192.168.45.2 \
    to-ports=8080
add action=dst-nat chain=dstnat comment="NAT PROXY" disabled=no dst-port=\
    80,81,8080,3128 in-interface=to_hotspot protocol=tcp to-addresses=\
    192.168.45.2 to-ports=8080

/ip firewall layer-7 protocol

 add comment="" name=http-video regexp="http/(0\\.9|1\\.0|1\\.1)[\\x09-\\x0d ][\
    1-5][0-9][0-9][\\x09-\\x0d -~]*(content-type: video)"

/ip firewall mangle


add action=mark-packet chain=forward comment="Mark Hit" disabled=no dscp=12 \
    new-packet-mark=proxy-hit passthrough=no
add action=mark-connection chain=prerouting comment="awal load balance" \
    connection-state=new disabled=no in-interface=proxy new-connection-mark=\
    PROXY-1 passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-state=new \
    disabled=no in-interface=proxy new-connection-mark=PROXY-2 passthrough=\
    yes
add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local dst-port=80,81,8080,3128 in-interface=proxy \
    new-connection-mark=PROXY-1 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/0 protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local dst-port=80,81,8080,3128 in-interface=proxy \
    new-connection-mark=PROXY-2 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/1 protocol=tcp
add action=mark-connection chain=prerouting comment="" connection-mark=\
    PROXY-1 disabled=no in-interface=proxy new-connection-mark=PROXY-1 \
    passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-mark=\
    PROXY-2 disabled=no in-interface=proxy new-connection-mark=PROXY-2 \
    passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=PROXY-1 \
    disabled=no in-interface=proxy new-routing-mark=Route-Proxy-1 \
    passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=PROXY-2 \
    disabled=no in-interface=proxy new-routing-mark=Route-Proxy-2 \
    passthrough=yes
add action=mark-connection chain=input comment="Awal LoadBalance local" \
    connection-state=new disabled=no in-interface=local new-connection-mark=\
    ADSL-1 passthrough=yes
add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=local new-connection-mark=ADSL-2 passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-mark=ADSL-1 \
    disabled=no in-interface=local new-connection-mark=ADSL-1 passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-mark=ADSL-2 \
    disabled=no in-interface=local new-connection-mark=ADSL-2 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=ADSL-1 \
    disabled=no in-interface=local new-routing-mark=jalur-1 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=ADSL-2 \
    disabled=no in-interface=local new-routing-mark=jalur-2 passthrough=yes
add action=mark-connection chain=input comment="Awal LB Hotspot" \
    connection-state=new disabled=no in-interface=to_hotspot \
    new-connection-mark=ADSL-1 passthrough=yes
add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=to_hotspot new-connection-mark=ADSL-2 \
    passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-mark=ADSL-1 \
    disabled=no in-interface=to_hotspot new-connection-mark=ADSL-1 \
    passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-mark=ADSL-2 \
    disabled=no in-interface=to_hotspot new-connection-mark=ADSL-2 \
    passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=ADSL-1 \
    disabled=no in-interface=to_hotspot new-routing-mark=jalur-1 passthrough=\
    yes
add action=mark-routing chain=prerouting comment="" connection-mark=ADSL-2 \
    disabled=no in-interface=to_hotspot new-routing-mark=jalur-2 passthrough=\
    yes
add action=mark-connection chain=prerouting comment=DISABLE-PROXY-DOWN \
    disabled=no dst-address-type=!local dst-port=!80,81,8080,3128 \
    in-interface=local new-connection-mark=ADSL-1 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local dst-port=!80,81,8080,3128 in-interface=local \
    new-connection-mark=ADSL-2 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/1 protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local dst-port=!80,81,8080,3128 in-interface=to_hotspot \
    new-connection-mark=ADSL-1 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/0 protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local dst-port=!80,81,8080,3128 in-interface=to_hotspot \
    new-connection-mark=ADSL-2 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/1 protocol=tcp
add action=mark-connection chain=prerouting comment=ENABLE-PROXY-DOWN \
    disabled=yes dst-address-type=!local in-interface=local \
    new-connection-mark=ADSL-1 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting comment="" disabled=yes \
    dst-address-type=!local in-interface=local new-connection-mark=ADSL-2 \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-connection chain=prerouting comment="" disabled=yes \
    dst-address-type=!local in-interface=to_hotspot new-connection-mark=\
    ADSL-1 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting comment="" disabled=yes \
    dst-address-type=!local in-interface=to_hotspot new-connection-mark=\
    ADSL-2 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/1
add action=mark-connection chain=prerouting comment="QOS LINE 1" disabled=no \
    in-interface=pppoe-speedy1 new-connection-mark=qos_downstream.1 \
    passthrough=yes
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.1 disabled=no new-packet-mark=icmp.pkt.1 passthrough=no \
    protocol=icmp
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.1 disabled=no new-packet-mark=dns.pkt.1 passthrough=no \
    protocol=udp src-port=53
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.1 disabled=no new-packet-mark=game.pkt.1 passthrough=no \
    protocol=tcp src-port=\
    843,1818,2001,3010,4300,5105,5121,5126,5171,5340-5352,6000-6152,7777
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.1 disabled=no new-packet-mark=game.pkt.1 passthrough=no \
    protocol=tcp src-port="7341-7350,7451,8085,9600,9601-9602,9300,9339,9376-9\
    377,9400,9700,10001-10011"
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.1 disabled=no new-packet-mark=game.pkt.1 passthrough=no \
    protocol=tcp src-port="10402,11011-11041,12011,12110,13008,13413,15000-150\
    02,16402-16502,16666,18901-18909,19000"
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.1 disabled=no new-packet-mark=game.pkt.1 passthrough=no \
    protocol=tcp src-port=\
    19101,22100,27780,28012,29000,29200,39100,39110,39220,39190,40000,49100
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.1 disabled=no new-packet-mark=game.pkt.1 passthrough=no \
    protocol=udp src-port="1293,1479,6100-6152,7777-7977,9401,9600-9602,12020-\
    12080,30000,40000-40010"
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.1 disabled=no new-packet-mark=game.pkt.1 passthrough=no \
    protocol=udp src-port=42051-42052,11100-11125,11440-11460
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.1 disabled=no layer7-protocol=http-video new-packet-mark=\
    http-video.pkt.1 passthrough=no protocol=tcp src-port=80,8080,3128
add action=mark-packet chain=prerouting comment="" connection-bytes=0-131072 \
    connection-mark=qos_downstream.1 disabled=no new-packet-mark=\
    http-small.pkt.1 passthrough=no protocol=tcp src-port=80,8080,3128,443
add action=mark-packet chain=prerouting comment="" connection-bytes=131072-0 \
    connection-mark=qos_downstream.1 disabled=no new-packet-mark=\
    http-big.pkt.1 passthrough=no protocol=tcp src-port=80,8080,3128,443
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.1 disabled=no new-packet-mark=other.pkt.1 passthrough=no
add action=mark-connection chain=prerouting comment="QOS LINE 2" disabled=no \
    in-interface=pppoe-speedy-2 new-connection-mark=qos_downstream.2 \
    passthrough=yes
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.2 disabled=no new-packet-mark=icmp.pkt.2 passthrough=no \
    protocol=icmp
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.2 disabled=no new-packet-mark=dns.pkt.2 passthrough=no \
    protocol=udp src-port=53
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.2 disabled=no new-packet-mark=game.pkt.2 passthrough=no \
    protocol=tcp src-port=\
    843,1818,2001,3010,4300,5105,5121,5126,5171,5340-5352,6000-6152,7777
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.2 disabled=no new-packet-mark=game.pkt.2 passthrough=no \
    protocol=tcp src-port="7341-7350,7451,8085,9600,9601-9602,9300,9339,9376-9\
    377,9400,9700,10001-10011"
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.2 disabled=no new-packet-mark=game.pkt.2 passthrough=no \
    protocol=tcp src-port="10402,11011-11041,12011,12110,13008,13413,15000-150\
    02,16402-16502,16666,18901-18909,19000"
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.2 disabled=no new-packet-mark=game.pkt.2 passthrough=no \
    protocol=tcp src-port=\
    19101,22100,27780,28012,29000,29200,39100,39110,39220,39190,40000,49100
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.2 disabled=no new-packet-mark=game.pkt.2 passthrough=no \
    protocol=udp src-port="1293,1479,6100-6152,7777-7977,9401,9600-9602,12020-\
    12080,30000,40000-40010"
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.2 disabled=no new-packet-mark=game.pkt.2 passthrough=no \
    protocol=udp src-port=42051-42052,11100-11125,11440-11460
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.2 disabled=no layer7-protocol=http-video new-packet-mark=\
    http-video.pkt.2 passthrough=no protocol=tcp src-port=80,8080,3128
add action=mark-packet chain=prerouting comment="" connection-bytes=0-131072 \
    connection-mark=qos_downstream.2 disabled=no new-packet-mark=\
    http-small.pkt.2 passthrough=no protocol=tcp src-port=80,8080,3128,443
add action=mark-packet chain=prerouting comment="" connection-bytes=131072-0 \
    connection-mark=qos_downstream.2 disabled=no new-packet-mark=\
    http-big.pkt.2 passthrough=no protocol=tcp src-port=80,8080,3128,443
add action=mark-packet chain=prerouting comment="" connection-mark=\
    qos_downstream.2 disabled=no new-packet-mark=other.pkt.2 passthrough=no
add action=mark-connection chain=prerouting comment="ICMP " disabled=no \
    new-connection-mark=ICMP-CM passthrough=yes protocol=icmp
add action=mark-connection chain=postrouting comment="" disabled=no \
    new-connection-mark=ICMP-CM passthrough=yes protocol=icmp
add action=change-dscp chain=prerouting comment="" connection-mark=ICMP-CM \
    disabled=no new-dscp=5 protocol=icmp
add action=change-dscp chain=postrouting comment="" connection-mark=ICMP-CM \
    disabled=no new-dscp=5 protocol=icmp
add action=mark-packet chain=prerouting comment="" connection-mark=ICMP-CM \
    disabled=no new-packet-mark=PRE-ICMP-PM passthrough=no protocol=icmp
add action=mark-packet chain=postrouting comment="" connection-mark=ICMP-CM \
    disabled=no new-packet-mark=POST-ICMP-PM passthrough=no protocol=icmp

/queue type

 set default kind=pfifo name=default pfifo-limit=50
set ethernet-default kind=pfifo name=ethernet-default pfifo-limit=50
set wireless-default kind=sfq name=wireless-default sfq-allot=1514 \
    sfq-perturb=5
set synchronous-default kind=red name=synchronous-default red-avg-packet=1000 \
    red-burst=20 red-limit=60 red-max-threshold=50 red-min-threshold=10
set hotspot-default kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=\
    5
add kind=pcq name="PCQ down" pcq-classifier=dst-address pcq-limit=50 \
    pcq-rate=512000 pcq-total-limit=2000
add kind=sfq name=parent-limiter sfq-allot=1514 sfq-perturb=10
add kind=sfq name=client-limiter sfq-allot=1514 sfq-perturb=5
set default-small kind=pfifo name=default-small pfifo-limit=10

/queue tree

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=2M name=Speedy.1 parent=global-in priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1800k name=HTTP.1 parent=Speedy.1 priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=2M name=Speedy.2 parent=global-in priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1800k name=HTTP.2 parent=Speedy.2 priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=ICMP.1 packet-mark=icmp.pkt.1 parent=Speedy.1 priority=1 \
    queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=DNS.1 packet-mark=dns.pkt.2 parent=Speedy.1 priority=1 \
    queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1M name=VIDEO.1 packet-mark=http-video.pkt.1 parent=HTTP.1 \
    priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=SMALL.1 packet-mark=http-small.pkt.1 parent=HTTP.1 \
    priority=5 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1M name=BIG.1 packet-mark=http-big.pkt.1 parent=HTTP.1 \
    priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=GAME.1 packet-mark=game.pkt.1 parent=Speedy.1 priority=1 \
    queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1M name=OTHER.2 packet-mark=other.pkt.2 parent=Speedy.2 \
    priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=DNS.2 packet-mark=dns.pkt.2 parent=Speedy.2 priority=1 \
    queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=GAME.2 packet-mark=game.pkt.2 parent=Speedy.2 priority=1 \
    queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1M name=BIG.2 packet-mark=http-big.pkt.2 parent=HTTP.2 \
    priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=SMALL.2 packet-mark=http-small.pkt.2 parent=HTTP.2 \
    priority=5 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1M name=VIDEO.2 packet-mark=http-video.pkt.2 parent=HTTP.2 \
    priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1M name=OTHER.1 packet-mark=other.pkt.1 parent=Speedy.1 \
    priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=ICMP.2 packet-mark=icmp.pkt.2 parent=Speedy.2 priority=1 \
    queue=default
add burst-limit=30M burst-threshold=2M burst-time=3s disabled=no limit-at=0 \
    max-limit=20M name="P HIT" packet-mark=proxy-hit parent=global-out \
    priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=64k name=PING packet-mark=PRE-ICMP-PM parent=global-in \
    priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=64k name=PING. packet-mark=POST-ICMP-PM parent=global-out \
    priority=8 queue=default

/queue simple

add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
    direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
    0/0 max-limit=0/0 name=0-MAIN-0 parent=none priority=8 queue=\
    default-small/default-small total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
    direction=both disabled=no dst-address=0.0.0.0/0 interface=to_hotspot \
    limit-at=0/0 max-limit=512k/2M name=HOTSPOT parent=0-MAIN-0 priority=8 \
    queue=default-small/default-small total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
    direction=both disabled=no dst-address=0.0.0.0/0 interface=local \
    limit-at=0/0 max-limit=1M/5M name=LOCAL parent=0-MAIN-0 priority=8 queue=\
    ethernet-default/ethernet-default total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment=\
    "Warnet Lintang" direction=both disabled=no dst-address=0.0.0.0/0 \
    interface=all limit-at=128k/128k max-limit=128k/256k name=\
    Server_lintangNet parent=LOCAL priority=1 queue=default/default \
    target-addresses=192.168.32.2/32 total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
    direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
    128k/128k max-limit=128k/256k name=KBU-1 parent=LOCAL priority=1 queue=\
    default/default target-addresses=192.168.32.3/32 total-queue=\
    default-small

/ip route


add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=
xxx.xxx.xxx.xxx,xxx.xxx.xxx.xxx scope=30 target-scope=10
add check-gateway=arp comment="" disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=
xxx.xxx.xxx.xxx routing-mark=Route-Proxy-2 scope=30 target-scope=10
add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=
xxx.xxx.xxx.xxx routing-mark=jalur-2 scope=30 \
    target-scope=10
add check-gateway=ping comment=jalur-1 disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=
xxx.xxx.xxx.xxx routing-mark=jalur-1 scope=30 target-scope=\
    10
add check-gateway=arp comment=jalur-1 disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=
xxx.xxx.xxx.xxx routing-mark=Route-Proxy-1 scope=30 \
    target-scope=10



5 komentar:

  1. klo buat 1 line apa aja yg di hapus mas?

    BalasHapus
  2. QoS speedy 2nya di hapus di mangle sama di queue tree

    BalasHapus
  3. Kalau yg untuk game di hapus ? Bw di limpahkan untuk browsing saja ditambah apa aja ?

    BalasHapus
  4. Kalau yg untuk game di hapus ? Bw di limpahkan untuk browsing saja ditambah apa aja ?

    BalasHapus
  5. Hapus packet games yang ada di quetree dan limit BW yang ada di que tree tambahkan pada packet browsing

    BalasHapus